When installing a new version please remember to remove the old version first. Instructions can be found here

Pluskit 2.40
July 28, 2013
  • Fix Problems with OSX 10.9/Beta 4 Mavericks
  • Remove Growl depedency
  • Requires OSX 10.7 or greater


Pluskit 2.31
  • Should improve @import in some situations (especially with RapidAlbum)

Pluskit 2.30
  • Should improve @import in some situations (especially with RapidAlbum)

PlusKit 2.28
Feb 24, 2012
  • Fixes a crashing problem with 10.6 Snow Leopard

PlusKit 2.27
Feb 20, 2012
  • Improvements to allow gdoc to work again
  • Improved @import compatibility

PlusKit 2.25
Sep 13, 2011
• I'm sorry to report that this version removes backup support for all users running version 5.2 or greater of RW.

PlusKit 2.23
Aug 25, 2011
• Re-added PPC builds (for now)
• Fixed (Hopefully) a problem some people had with the plugin now installing properly in Lion.

PlusKit 2.22
Aug 20, 2011
• Another lion crasher resolved

PlusKit 2.20
Aug 5, 2011

  • Fixes lion problems by removing the backup feature - sorry folks but the backup feature fundamentally will not work in Lion -- Use time machine instead
  • Misc fixes



PlusKit 2.14
Feb 25, 2011

  • Better diagnostics if a server doesn't support @gdoc
  • Fixed a problem where @gdoc would change page styles
  • Fixed a nasty crasher


PlusKit 2.10
  • Further improvements to new style gdoc
  • New Fancy Box using newer version of Jquery
  • Improved lightboxing in RW5

PlusKit 2.09
  • Fixed broken ?edit in gdoc (you can now, again, add ?edit to the end of a gdoc page and a little edit link shows up)
  • Removed log messages that were appearing in the console


PlusKit 2.07
Nov 1, 2010
  • Upgraded mootools to newest version to fix problems with lightbox on chrome.
  • New gtable themes -- see here for more details
  • New styled text conditional text @if((test))/@endif(()) for optionally excluding or including a section of text (great if you want different things on export vs. publish vs. preview (see http://loghound.com/pluskit/pluskit-if/index.html)

PlusKit 2.06
Nov 1, 2010
  • Compatability

PlusKit 2.05
Oct 6, 2010
  • New style google docs should work better with @gdoc

PlusKit 2.03
May 2, 2010
  • Fixed a problem where the CSS for some table themes wouldn't work for some table
  • Fixed a problem where insert on page would not always work reliably.

PlusKit 2.01
Dec 9, 2009
  • New gtable themes & features. theme:native will give you the native spreadsheet format with all formatting in the spreadsheet and autofilter:true will do a filtered table
  • Improvements to @import handling of certain page types (most notably stacks) -- will properly include stylesheet.

PlusKit 2.00
October 3, 2009
  • See here for details on upgrading
  • Leopard or Snow Leopard Only
  • New Lightbox Effect
  • New 'insert on page' snippit feature
  • Lots of internal clean ups and improvements

PlusKit 1.58
March 25, 2009
  • Adds support for the new drawing mode in google docs -- If you use the @gdoc command this version will properly display any drawings you add.

PlusKit 1.57
Feb 10. 2009
  • Various fixes to re-enable the ?edit feature (add ?edit to the end of a URL and it brings up a edit window)
  • Fixes to @gform -- Previously if you marked a form entry as required and it wasn't filled in gform would quietly swallow it. Now it complains and gives you a chance to re-enter (very nicely highliting the missing fields)
  • Moved the registration to the setup window as god intended it to be. Pluskit now requires at least RW 3.6

PlusKit 1.54

  • Fixes a problem with @gdoc after a google change.

PlusKit 1.53

  • Provides a work around to the current @gdoc problem. Google is having a problem with how they serve up documents in some cases. Since it's still not fixed I decided to push out a work around. You'll need to re-publish any gdoc pages to have this take effect. There is a (small) chance this fix won't work for some non-english users, if you still set it let me know.

PlusKit 1.52

  • Fixed a problem where preview of @gdoc and friends wouldn't preview correctly if the page was multiple levels down in RapidWeaver 4.1. (This only effected preview mode so if you weren't seeing any problems or don't use the google doc type functions you can safely ignore this update.)


PlusKit 1.51

  • Fixed problem with loading in RapidWeaver 3.6 -- It should now work properly in both 4.x and 3.6 (although the 'automatic update' sparkle feature only works in 4.x)

PlusKit 1.50

  • Fixed a problem importing HTML page types
  • Added Sparkle Support for Pluskit (A big thanks to Isaiah at YourHead for doing the heavy lifting on this one) -- If you experience any problems loading this please let me know (include the version of RapidWeaver you are using)



Version 1.48
Aug 21, 2008
  • Fixed problem importing pages that had folder names with underscores.

Version 1.46
July 18, 2008
  • Improved importing of pages -- it now works more reliably even under extremely complicate scenarios.


Version 1.45
July 7, 2008
  • Fixes a problem with @gform caused by a recent google update where the form values were not entered in the spreadsheet. The fix was done in a way that should be very robust even if google changes things again
Version 1.44
June 25, 2008
  • Fixes a problem where some backups would fail to compress
  • Fixes a problem where the automatic lightbox triggers would not work with some alt titles.


Version 1.42
June 4, 2008
  • Fixes a error "Collection was mutated while being enumerated"