Looking for a few brave souls

Hello All,

I've been working on a new version of RapidBlog and I need a few folks to help me test it out. Currently I only have one other person who has been kind enough to test it and I'm ready to expand it out a bit.

Before you volunteer I need to make one thing clear. This version is not backwards compatible. What this means is after you upgrade to 1.2 you can't go back to 1.1.

While I'm commited to working with everyone to make sure it works for them please don't ask for a 1.2beta unless you are willing to 'stick with it' and are willing to have something potentially broken on your blog with the only way to fix it is for me to send you a new build.

If you are interested drop me a line using the usual channels.
Comments (1)

I am so weak

I told everyone who would listen "I'm not going to get one". Way overpriced and my treo does everything I need it to do.

I am so weak.
I'm so weak
Comments (3)

Thanks Apple

I just spent the last 3 days pulling what's left of my hair out. A few customers were having weird PlusKit problems -- The symptoms weren't always exactly the same but similar enough for me to know that something was afoot -- The problem was everything worked great for me, I saw absolutely no problem.

The problem? Safari 3.0 beta. When Apple packaged up the safari 3.0 beta the installed a brand new WebKit framework in the systems folder. What does this mean? It mean's anything that uses WebKit will use the new (beta?) version of web kit.

A freakish amount of apps use WebKit including RapidWeaver with the result that you are now using a untested configuration of RapidWeaver. It turns out that PlusKit uses one small webkit function to help convert HTML entities to UTF8 characters that is broken in the WebKit beta which was the root cause.

I just pushed up a new version of PlusKit (1.04) that should work regardless if you have Safari 2.0 and Safari 3.0, it's highly recommended.

Comments (2)

New RapidBlog

As luck would have it Blogger changed their feed in a way that broke RapidBlog today. I've been at WWDC all week and pretty tied up with those sessions so it was a shock when I logged into email and discovered the problem.

I'm sorry for anyone who had a problem -- I've pushed a new version up (1.17) that you can find in the
usual places. It's recomended for all users -- Just make sure you mark the RapidBlog as needing an update and republish to get the fix.



Comments

Going Quiet

I've been working on a major overhaul of RapidBlog -- Before you get too excited I need to be clear that (so far) the changes are all internal -- I'm completely re-doing my syncing & back end communications to blogger. The old engine actually worked pretty well but I had a defect come in (the dreaded 404/resource not found) and I spent about two days looking at the code for the best way to fix it. It was then I realized that
  1. I was scared to touch the code
  2. There were sections that were there for reasons I don't remember why I did it.
This was a sure sign to me that I needed to do what we call refactoring. Basically I decided to re-do the entire engine taking all of the learnings I had to make it into something more stable & robust. The upshot of this is that I have had my head down pretty low working on the internal guts -- I hope when 1.2 comes out to add a bunch of new/requested features but for now at minimum I want to roll out my new engine. -John
Comments (1)

Plugin Sale


Buy any 3 plugins and use the coupon code RW36ROCKS

Sale Ends May 25th 9:00pm Pacific Time

Comments

A note about 3.6

By the time you read this RW3.6 will have landed. I've been testing it for a while and overall I think you'll be happy with it. I wanted to comment on a few specifics with regards to my Plugins and RW3.6

  • All of my plugins should work fine with RW3.6. The one known problem is that the SiteMap plugin will not show blog archives -- I'm working on a fix and hope to have one out eventually but I wasn't able to resolve the issues around it in time. Download 1.38 or greater and enjoy trouble free sitemaps in RW3.6 and RW3.5
  • I do plan on enhancing RapidBlog to take advantage of the tag clouds

So while I have been testing against RW3.6 there is a possibility that something is not right -- If you do find a problem please let me know.


Comments

Email Hell

Just a short note -- I just discovered that somehow I'm missing some emails -- I don't know where the problem is (yet) and I think I've found all of the missing ones but if you sent me a note and haven't received a response please go ahead and resend it. Sorry for the problem. -John
Comments (1)

Chumby


I want my Chumby, if you haven't seen it run over and a take a look. It's a very cool alarm clock and is Exactly what I've been wanting for a while.

I've been watching the chumby site for what feels like a year now and they have stilll not released it. Comeon guys, release the chumby to the world!

-John
Comments

Blogger Down

Parts of blogger were down over the last 18 hours. It now is back up. If you have experienced RapidBlog problems (blog now showing up, strange errors, etc.) it should all be working now.
Comments

Next Page -->